COMMUNITY FORUMS

Return to: Forums » Rants and Raves » Did I get a lemon?
Subject: Did I get a lemon?
Author: SamC (07:38PM, May 31, 2010 - last edited 07:40PM, May 31, 2010)
 
Received my Outcast about two weeks ago, and after just two or three sessions (just listening to music on the deck, nothing excessive) it appears that all the buttons on the button panel have ceased functioning. Specifically, the ON button does not respond and does not turn the unit on; as a test, the downfiring light does not come on. Obviously I can't check the Play etc buttons as the unit will not power on.

The problem exists whether the unit is connected to mains power or running from the battery. When plugged into mains, the battery light illuminates briefly -- unit must be getting power, but I assume the battery is full.

Obviously, after only two or three uses, this is pretty disappointing and will be seeking a refund or replacement from my retailer.
Sign In or Create an Account to Reply to this Topic
Subject: re: Did I get a lemon?
Author: OmarV (09:10AM, Jun 01, 2010)
 
Sam, I'm sorry to hear you're unit is failing. If this happened spontaneously (meaning there were no accidents or unusual situations involved) the best thing to do is going back to your dealer for a replacement unit. I will ask you for a favor though, can you provide me with the serial number of this unit.
You can email it to [email protected] Thanks!
Sign In or Create an Account to Reply to this Topic
Subject: re: Did I get a lemon?
Author: SamC (04:11AM, Jun 11, 2010)
 
Hi Omar,

I have supplied the serial number to my retailer, as he has requested. It seems there was a 'bad batch' of Soundcasts that had faulty touchpads there were distributed to Australia, New Zealand and the Middle East.

While I understand that mistakes are made on the production floor, the attitude I seem to be getting is, The Customer can wait while we sort out our easiest way out of this mess.

I think that's an appalling customer relations tactic, to be frank. I waited six weeks for delivery of my Outcast, used it three times -- THREE -- and all I am hearing is that I have to wait until Soundcast makes up its mind what it wants to do. I've spent $1200 and effectively have nothing to show for it.
Sign In or Create an Account to Reply to this Topic
Subject: re: Did I get a lemon?
Author: OmarV (09:37AM, Jun 11, 2010)
 
Sam,

We are in the process of replacing all of the units shipped in this lot. Unfortunately, the manufacturing process is lengthy due to the lead times of some of the components. As soon as possible, we will be shipping these replacements to your dealer. As a way of apology for your inconvenience, we would like to give you one of our transmitters (a UAT). Please contact me at our offices and we will arrange for this.
[email protected]

Thanks
Sign In or Create an Account to Reply to this Topic
Subject: re: Did I get a lemon?
Author: SamC (01:48PM, Jun 16, 2010)
 
Thanks Omar, I have sent you an email.
Sign In or Create an Account to Reply to this Topic
Return to: Forums » Rants and Raves